Forum rules - please read before posting.

Voice Clips Not Playing In ActionLists

I'm not sure what information I can add about this but all my NPC voice clips play flawlessly and as they should do apart from when they're played from within an ActionList.

When called from an ActionList they don't play their voice clips at all.

The audio clips are named correctly and have a fixed Constant ID in the ActionList like the image below, is this correct?

There is no voice clips for the Player yet so I haven't tested that.

image

Comments

  • Do the subtitles appear, or is the whole Action ignored?
  • The subtitles appear fine. Tried with a player voice clips too during the actionlist and that too is ignored. The subtitles play fine still.
  • In what version of AC?  Please post your full Speech Manager as well.

    If you temporarily uncheck Auto-name speech audio files?, you'll be able to manually link audio files to lines in the Speech Manager.  If you link the audio to the problematic lines manually, do they then play?
  • It's the latest version 1.55a, with Unity 5.5.

    I'll try what you've suggested and let you know how you get on. In the meantime, here's the Speech Manager:

    image
  • UPDATE: I've tried manually assigning the sound clips to the problematic lines but they still won't play from within the ActionList.
  • Odd.  And what about audio for lines that were playing fine when the linking was automatic?  I'm assuming you mean those ones are from scene-based ActionLists, such as Cutscenes.
  • edited December 2016
    No speech files played when I deselected the Auto-name speech files at all.

    Any other speech lines appear to be working fine, it's just when an asset file ActionList is called they refuse to play.

    I also noticed that the asset file ActionLists' speech ID numbering is totally different to the one generated from the scripts. I haven't changed a thing for them to be different. In fact, even now, if I generate a script after a re-gather, those ActionList speech IDs don't match the ones in the script.

    Still, even when temporary renaming the speech files to match up with the ActionList speech IDs it still doesn't work.

    I'm completely baffled.
  • Please give me an example of a mistmatch between the Action's Speech ID and the script ID.  Are you referring to the line listed in the Speech Manager, or in an exported translation file?
  • edited December 2016
    image
    image
    image

    As you can see, the ActionList Speech ID is totally different to both the script and the Speech Manager IDs. There's only the one instance where this line is said too.

    Renaming the file to Michelle2171.wav doesn't make a difference either.

    Would a Rest Text be worthwhile and then a re-gather?
  • I can't tell by this point how a mismatch would have been created, but first backup the project so that all can be reverted.  Try a re-gather and see if that corrects the links.  If not, let me know the details, and then try a reset + re-gather.
  • Hi Chris.

    Exactly the same problem after a reset and re-gather. I'm absolutely lost.
  • How is this ActionList run, exactly?  Create a unitypackage file of your Managers, and the offending ActionList, and PM it to me.
  • It's run by simply calling an asset file outside the scene during a running conversation. I'll package them up and send them today for you. Thanks for your help with this, Chris.
  • edited January 2017
    Hi
    this thread is fresh, and i think can be connected to my problem, so i will add in it, instead of new one

    I have a problem with Speech of Player, NPC, and Narrator using "auto name speech files" and gathering text, but before me explaining the problem and cure that I found

    pls Chris check this bug and explain what is wrong

    Unity 5.5.0 f3 Adventure Creator 1.55b
    1. new project
    2. import Adventure Creator 1.55b
    3. load basement demo
    4. play, speech files play ok
    for example ActionList "Intro1" in step 10 plays Dialogue "Hi!" "Brain11" file playes ok ... and so on
    5. stop
    6. go to GameEditor > Speech >
    in "Game text" section there is only one dialogue ? why
    7. Click > Gather text
    nothing new happens and "Game text" section shows the same
    8. run game
    9. characters are mute, subtitles show up, and console shows "Cannot find audio file: Speech/11"
  • Welcome to the community, @poliman.

    6. go to GameEditor > Speech > in "Game text" section there is only one dialogue ? why

    You must use the filter options above to show the game text you're looking for.  By default, it lists speech text placed outside of scene files - and the demo game only has one.  You can change the Scene filter to Any Or No Scene or Basement to show the others.

    7. Click > Gather text nothing new happens and "Game text" section shows the same

    AC is only able to search scenes that have been added to your game's Build settings.  Before you click Gather text, first go to File -> Build Settings and add the scene to the list of scenes in your game's build.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!