Forum rules - please read before posting.

Player disappears randomly when I make build

Hi everyone,
I had a strange porblem: I made a little 2d point and click adventure (a test with 3 rooms) context sensitive, using Unity 5.3.1f1 and AC 1.50g.

When I test it inside Unity I have no problem and my player is always visible (when he walks, takes a object, goes to a hotspot), but when I made the build (windows x86) my player disappears randomly: when I start the game he is in the room, but when I start to look a hotspot, open a drawer, he disappears. If I go to another room and then come back he re-appears.

But I can't understand where's the problem.


Comments

  • On what platform?  Unity 5.3 has been the cause of many strange problems - please update to AC v1.51b and see if the fixes included solve the issue.
  • i would like to interject. Try and do a reimport. sometimes a build does things different to the editor. I find a reimport makes the editor behave like it will be in build again.  I found this to work, and do it once every 1-2 months just to make sure XD

    Note: large games will take a long time to re-import, but three scenes should be pretty swift.

    worth a go :)

  • Hi Chis and hi klarax,
    thank for all the responses.

    At the end I solved making the update to 1.51b.

    Thank you very much
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!