Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Hotspots not triggering after a change scene script

edited May 2014 in Technical Q&A
Hi,

I'm having a problem with hotspots not triggering after a change scene script.

The room works correctly when I run it directly, and when clicked the hotspots cause the character to walk to a marker and the correct actions to play.

However, when I load this same room via a Change Scene action within a cutscene, it opens the correct scene, detects the hotspots (the cursor changes on mouse over), and I'm able to walk around by clicking on the navmesh after the cutscene finishes. But nothing happens when I click on the hotspots themselves. The player does not walk to marker, and the interactions do not play. 

I'm not sure what else to try. Is there a setting related to changing scenes in cutscenes that I'm missing?

Thank you,
Lisa

Comments

  • Sounds like a bug, unless you've deactivated the Interaction somehow.  You certainly don't have to worry about such settings when changing scenes.

    Post a screenshot of your full Hotspot Inspector when it doesn't work.  I understand your problem but I don't have enough detail to recreate it.
  • Thanks for your help,

    I've attached a couple of screens shots of one of the hotspots in the inspector, along with it's interaction. I'm not sure if this is what you mean by Full Hotspot Inspector, sorry.

    When I leave the game I return to the first scene which doesn't allow me access to the hotspots in the next scene. So I'm not sure how to check the hotspots without being in that scene, and when I run the game from that scene the hotspots work fine. 

  • Thanks.  Is this taken while the game is running and the Hotspot is not activating?  If not, please provide a comparison so we can see the difference between when it works and doesn't work.

    Also, to make it easier to test if the Interaction is being run or not, insert a new Action at the top of the Interaction list and set it to Engine: End game.  You can remove it afterwards, but it'll make it easier to find the source of the problem.
  • I created a new set of Managers which let me work out that I had messed up the previous ones by deleting various things in the Menu and Cursor Managers, and using the wrong methods in the Interface Settings. All fixed now, not a bug, and working fine. 

    Thanks for your help :)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!