Forum rules - please read before posting.

Ouya Build Issues

When I try to build the game to Ouya, I receive the following error in the console whilst compiling scripts:

Assets/AdventureCreator/Scripts/Static/OuyaIntegration.cs(17,7): error CS0246: The type or namespace name `tv' could not be found. Are you missing a using directive or an assembly reference?

I've tried re-importing AC but still get the issue. I'm confused as to what this even means.

Any help would be very much appreciated.


  • The namespace "tv" is used by the latest ODK, and is needed to build Ouya games.  Are you using the latest version?
  • I've downloaded it but haven't got a clue where I should save those files or how to link them up in Unity :/
  • And do you mean the Ouya ODK (If so what do I with the files in that ZIP?) or the Ouya SDK package to import into Unity?
  • Is the Edit button for the posts missing?

    Anyhow, I've fixed that and got it running on the Ouya (yay!) but the problem now is the Ouya buttons/mousepad don't seem to respond at all.

    I've tried it as 'Mouse & Keyboard' and 'Keyboard & Controller', have Playing On Ouya Platform ticked and OUYAIsPresent added under the Android Player Settings.

    Any ideas why this is?
  • I believe you need to build it first before you can use the controller - are you testing this in-editor?
  • No, this is from a build playing on the Ouya.

    Do I need to change any settings in the Ouya Panel in Unity?
  • I'm still having no luck with this. Has anyone else successfully ported to Ouya and had the controller working? If so, what's your setup? 
  • One thing you might want to look at: the OuyaIntegration.cs script.  It basically converts AC inputs to OUYA-compatible ones.  Should all be working, but clearly something's not right.
  • Thanks Chris but it's too confusing. I'm not sure if I've to install the Ouya package from the Ouya website at all and if so how does changing those settings in the Ouya Panel affect AC?

    Or does AC simply provide the complete Ouya files so we can publish straight to Ouya from AC?

  • You still need the Ouya package - the integration script just "bridges the gap" between the two packages.  The script essentially reads in the Ouya package's inputs, and uses them in AC.

    Are you sure that Ouya is set up properly?  Try building the SceneShowUnityInput scene that it comes with, to check that the button mappings work before trying to link with AC.
  • I'm sure that Ouya is installed correctly although not 100%. It compiles and runs but there's no controller function. It worked once but was extremely erratic and unusable.
  • I'm all for bugfixing AC's Ouya integration, but until we can determine for sure if it's AC or your Ouya installation, there's not much I can do.  Have you tried taking it to the Ouya forums?  There must be a quick way of testing an install.
  • I've got the Ouya package installed correctly and have got the controller working now but it's so laggy and erratic for some reason.
  • With AC or in general?
  • Once the build is sent to the Ouya, the Ouya controls/cursor are sluggish with what appears to be a 1 second framerate or there abouts. The gameplay itself is smooth.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.