Forum rules - please read before posting.

Adventure Creator cut scenes give UCC character a seizure

I'm using Unity 2019.4.8f1 with the latest versions of AC, UCC, and the official integration from the downloads page. I followed the instructions, adding AC_UCC_Character and the AC_Motion ability, switching the MainCamera tag off of UCC's camera on to AC's, etc. When running a cut scene and switching cameras, the UCC character seems to go a bit hayware – in third-person the head twitches back and forth, while in first-person the character spins in place.


  • edited September 2020

    Welcome to the community, @cfc.

    Apologies for the trouble. There're a lot of factors involved when dealing with two complex assets like this, so we'll need to do a bit of trial and error to find out what the cause is.

    Have you tried either of the demo scenes that come included with the integration package? Using the two Dummy Hotspots in both should demonstrate AC cutscenes overriding UCC control.

    If so, try disabling the Player character that's in the scene, and drop in your own Player prefab to replace it. Does the issue come back? If so, it's likely down to some difference between the two Players - comparing them may reveal the source.

    If not, it may be the cutscene itself - is this happening for all cutscenes? What are the properties and Actions of a cutscene that causes such problems, and how are you triggering it?

  • I actually can't get the cut scenes in the demo to play, even after trying in a clean project. Is the integration up to date for the latest versions?

  • I believe so, but I shall check.

    They aren't cutscenes, however, but interactions. You'll need to define an input named "InteractionA" in Unity's Input Manager, and then press that when near the Dummy Hotspots to trigger their Interactions.

    Assuming you've done this, what exactly is the behaviour? Does the Hotspot label appear when you approach either of the two Dummies?

  • Aha! I didn't have that input set up. I expected it to work with either the mouse click or the UCC action button. The UCC action button was working for the button, but nothing seemed to be working on the dummies. I have seen InteractionA mentioned in the manual, but I thought that was only necessary if disabling standard mouse interactions, and I didn't realize that was the case in the demo. Maybe I should have figured that out since clicking fires the gun, but it might be worth mentioning explicitly in the readme.

    The camera switch on the dummy doesn't cause the twitchy movement I'm seeing (though it doesn't handle first-person mode particularly well, but I guess if you have to include a "manual" switch out of first-person mode in any cut scenes that's not unreasonable), so I'll have to compare setups and experiment a bit to see if I can pin down the cause. Thanks for the help with troubleshooting this!

  • The UCC action button was working for the button, but nothing seemed to be working on the dummies.

    The Button is just demonstrating another way to interact with objects. While the two Dummies rely on AC's own Hotspot system, and so AC's InteractionA input, the Button relies on UCC's own interaction system, and so relies on UCC input.

  • @cfc Hey did you ever figure out the solution to the spinning problem?

  • Update: Fixed it by disabling the camera controller on the UCC camera through the object: Call event action

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.