Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Scrolling & Rich text

Hey-ho everyone - 

Just wanted to let you know that I noticed if you have "scroll audio" selected in your speech settings and have Rich Text flags in your text, it'll actually show the Rich Text handles as it's scrolling and then apply them at the end of the text block (after the scroll hits the closed bracket of the Rich Text handle).  

For example if I have a line in italics that says, "Hello, my name is themightyzq.", it'll show up as "<i>Hello, my name..." and then actually apply the italics after the scroll finishes.

Not sure if this is a known thing or if there's current workaround but thought I'd bring it up!

Comments

  • That shouldn't happen - AC checks for opening tags and adds closing ones dynamically.

    What are your AC and Unity versions, and are you displaying speech in an AC or Unity UI-based Menu?  Please also share an exact copy of a sample text you're attempting to display.
  • Unity - 5.6.4f1
    AC - 1.61.2
    It's an AC menu
    Here's a copy/paste:
    <i>"Curiously, all disagreements were set aside during this period.  They were not forgotten, but rather ignored until the week of the solstice was concluded.  Further, wars were delayed, and public offices, including schools, were closed..."</i>
  • Sorry, I don't have any problem with it.  Please try loading the 3D Demo game and running a new Cutscene that plays that text - does it still have issue?
  • Hmmmmm...Interesting.  I loaded up the demo and couldn't replicate it.  I even changed all of the managers to my own and it wouldn't replicate it...I load into my scene, made a new interaction, put the same text in, and it happens again. 

    Very strange.
  • ...and it doesn't happen in every scene.  

    <cue mysterious music>
  • If you convert the Interaction to an Asset File (via the cog icon in the Interaction Inspector), does it still not work as an asset?  If not, PM it to me and I'll look at it.
  • Realize this is late to the party, but I was just having problems with this myself and in my case, it was because I had accidentally capitalized the tags (eg. <B> instead of <b>). When I made them lowercase, it worked as intended. Thought I'd add that in case anyone else has the same problem...it might work for them too!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!