Forum rules - please read before posting.


edited June 2017 in Technical Q&A
I have a quick question, I'm using my controller to move between items in the inventory with the D-pad, but it moves right when I press down and left when I press up.. Is there a way to fix that? I've been trying to look for solution all day with no luck. Although, I know its simple..  (:|


  • edited July 2017
    The keyboard/controller navigation for AC-sourced Menus is admittedly very basic.  I can see about adding some tweaking options to the Menu's properties, but it's recommended to instead rely on Unity UI - which gives you full control over how Menus are navigated.

    A tutorial on integrating Unity UI with AC Menus can be found here, but again I'll see if tweaking options can be added.
  • edited July 2017
    ChrisIceBox, I did try to use Unity Ui but I encountered a problem. Whenever I run the game and open the menu, I cannot navigate between items until I use the mouse to click on one of the buttons first then I can use my D-pad to navigate. of course I tried to put one of the buttons as a"first selected" in the event system, but no luck. I also Checked "Auto-select first visible element" but with no luck as well, so I'm really kinda lost.. 

  • That should be given the attention, then, as UI-controlling should be working.

    Is the Menu set to pause the game when enabled?  If not, you'll need to use the Engine: Manage systems Action to allow keyboard-navigation.  By default, It's not enabled during normal gameplay so as not to intefere with player control.

    Was the first visible element not selecting?  The text you enter must be the name of the element as it appears in the Menu Manager - not the name of the UI GameObject.
  • Yes, the element is not selecting, I tried checking pause when enabled, and it didn't work, then I unchecked it and enabled   Engine: Manage systems: Control in-game menus, but still the first element is not selecting, and I can't navigate between the items until I use the mouse to click on one of the items first, then I can navigate using keyboard or controller.  I entered the text of the element correctly its by default "InventoryBox"  but no luck. :( 
    It's strange, when I made the Ui menu and put the first slot as "first selected" in the event system script, while on the hierarchy and I run the game without AC, it works fine and I can navigate using my controller or keyboard, so maybe I'm missing something on the AC menu manger, even tho I did everything correctly and I rechecked over 10 times already.. 
  • In what version of AC?

    The Menu Manager has some options related to keyboard vs mouse control over UI Menus - what are they set to?
  • edited July 2017
    My Unity version is 5.6.0f3.
    imageMy AC version is 1.56e, I haven't upgraded because my project is currently huge and slow, and I haven't made a back up yet.




    This is my current settings on the inventory menu I made and for the elements. 

    PS:I don't know why the picture won't show but right click on it then open in new window, so you can see it. 

  • Have you tried checking Auto-select first visible element? in the Menu's Properties box?
  • Yes I did, but it didn't change anything.. 
    I've been trying to solve it but I just can't figure out what's the problem, maybe the AC version I have?
  • It's always best to check the latest version before posting a bug report - even if it's in a duplicate project that doesn't affect your main one.

    If it still fails to work, PM me a .unitypackage file (not a zip) containing your 8 Managers and the UI prefab in question.
  • ChrisIceBox, I figured out what the issue is, but I couldn't fix it.

    Here is what I found:

    I'm using -Active input editor- to open the inventory menu via button press, and to add wait time + fade + other stuff, and everytime I open the menu with this method I can't navigate using my keyboard unless I click on the items with the mouse.

    However, when I open the inventory menu via Adventure creator> menu>Appear type on input key.  I can navigate through the menu and it works fine.. but I don't want to use this method.. Its too basic, and very quick to appear with no fade or wait time. :( 

    and so the issue here is that navigating using Unity UI menu is not working via -active input editor- ...

  • Oh wow I came to post this exact same issue.

    First selected not selecting on Unity UI.
    I am on Unity 5.5.0, AC v1.57a
    Movement method: Direct, Keyboard/Controller
    Checked "Disable mouse when keyboard-controlling Unity UI menus"
    First selected element is the Element Name of my Button.
    "Auto select first visible Element" doesn't work for me either.
    Selecting a Button with mouse allows me to navigate the other buttons, same as Neji states, but this is a Direct/Controller project as well.

    Have tried everything the original poster has tried. Would love to figure this out!
  • @Neji: Set the When running field of your Active Input's ActionList to Run In Background, as well as that the Menu's ActionList on turn on if it has one assigned.  Make sure that the Engine: Manage systems Action is called before the Menu: Change state.

    Again: if still no luck, PM me the Managers and the UI prefab - as well as the ActionList that the Active Input runs.  I will need to be able to recreate the issue myself.

    @brentk: Please post a screenshot of your full Menu's properties.
  • @ChrisIceBox

    And here is the UI prefab setup

    I am able to get the element focused if I use Alverik's SetUIFocus script but still strange I can't get it to work with AC's setup.
  • @brentk: How are you turning the Menu on?  Does it work if you switch it's Appear type on On Input Key and map it to an input listed in your Input Manager, in the same way that the default Pause Menu does?
  • @ChrisIceBox

    I was turning the menu on with an Action, Menu: Turn On Menu
    I set the Menu to Appear On Input Key, but it still does not highlight my Element until I click with mouse first
  • Are any other Menus open at the same time?

    Try the default Pause Menu - when switched to Unity UI, enter in ResumeButton as the element to highlight.  Does that work as intended?

    You may have to just PM me the assets involved.  It's pretty tough to guess what the issue is without seeing it for myself.
  • ChrisIceBox  Thank you so much !
    The issue indeed was just to Set the When running field of your Active Input's ActionList to Run In Background, and it worked like a charm. Thanks again!! :)  
  • edited October 2018
    Circling back around on improved D-Pad support and/or tweaking options as I've been having a number of issues with using a D-Pad when navigating menus.  I don't really have any issues with menu navigation using the keyboard or the analogue stick on the controller (although the analogue stick can sometimes "stick" on certain buttons and I'll have to press again for it to register), but when using the D-Pad, there are multiple times where it's completely unresponsive or goes a different direction than I'm pressing.

    I'm noticing this erratic behavior on pretty much every menu type.  Paused/Unpaused menus, grid based, inventory rows, etc, etc...

    Any pointers on improving D-Pad performance without rebuilding every menu with Unity-UI?  That's just not going to be achievable.  I have way too many menus that would have to be recreated.

    Thanks for any advice.  Happy to post any screenshots, share managers, unity packages, etc...
  • edited October 2018
    1. With what AC/Unity versions?
    2. What controller exactly?
    3. Does this occur with the default Pause menu?
    4. What are your Unity Input settings for the D-Pad buttons?
  • 1. AC 1.65.1/Unity 5.6.6
    2. Xbox 360 and Xbox One controllers
    3. Yes
    4. D-Pad Up: Vertical +, D-Pad Down: Vertical -, D-Pad Left: Horizontal -, D-Pad Right: Horizontal +
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.