Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Unity 2019.3 updating and support

edited February 9 in Technical Q&A

Hello,

Currently using Unity 2019.2.20f1 and AC 1.70.2

This post is mainly just to share info about issues that came up when attempting to update a project to 2019.3 (officially released a couple weeks ago).

I'm fine to hold off on updating to 2019.3 for a while. Of course I made a copy of my project before upgrading, and can continue with 2019.2.20f1 for now. Was just wondering if a project can be updated eventually, and if AC will support 2019.3 at some point.
Perhaps there's simply something I'd need to do in order for it to work with 2019.3?

In the first attempt to update a project, a prompt appeared asking if "you want to upgrade the project to use Asset Database Version 2":
https://imgur.com/a/XY5p5Pd

I clicked "Yes", and when everything finished it showed some errors in the console:
https://imgur.com/a/DSrg7vK

Then noticed that "Adventure Creator" wasn't in the menu bar at the top, nor was there a way to open the panel with the different managers. Tried to download and import it from the Asset Store.
There were less console errors after that though some remained:
https://imgur.com/a/WhBUpTZ

Next I tried a second attempt to update another fresh copy of the project (of 2019.2.20f1).
I clicked "No" in the prompt asking to upgrade the project to use Asset Database Version 2.
It imported the project with some new errors:
https://imgur.com/a/bQQW5oi

Unsure what these errors mean. They won't allow the project to be tested in Play mode, or built. Again just posting this info to help with future AC support!

Comments

  • It may be important mention the Unity version being upgraded to: 2019.3.0f6

  • AC should already be fine to use with Unity 2019.3 - though if issues are found and reported they will be dealt with.

    The AC toolbar is missing because you have a compilation error (the red message in your Console). This is not AC-related, but and error message will cause all third-party toolbars to disappear until its been resolved.

    The error appears to be related to the "2D IK" experimental package. You may need to upgrade it, or even remove it, from Unity's Package Manager. You may want to check on the official Unity forums first, but again - this specific issue is unrelated to AC.

  • That was it. Thank you for helping narrow it down.

    Just needed to update the "2D IK" package to the newest version.

    The "2D Animation" package is now out of preview, and officially released in 2019.3:
    https://forum.unity.com/threads/2d-animation-is-out-of-preview-for-2019-3.818724

    Thanks again!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!