Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Title screen menu showing only if not "Maximize On Play"

edited February 4 in Technical Q&A

Hello,
I'm having a particular bug.

I followed this tutorial: https://www.adventurecreator.org/tutorials/creating-title-screen-menu
Everything went well. I have a scene just with a background picture and the menu.

I play the game minimized and the menu is working correctly, the scene change and the game start.
But if i press "Maximize On Play", the menu is not showing anymore. At all.

I managed to let it appear in both ways, only going on the "title" menu and unchecking "Pausa game when Enabled?".
But then of course, the game is not paused. I don't get why this is happening.

I share a link with some images of the Title menu, the OnStart cutscene that shows the title menu and settings in the AC Game Editor.
https://imgur.com/a/AIiScAK

Here is a video showing the problem:

It is maybe something on the project settings?

It is maybe an order in layer too low?
I have images in the background with order in layer of 16.

I have last version of Unity and AC

Any help will be appreciated.

Mirko

Comments

  • I will attempt a recreation. Does this occur if you restart Unity, and then set "Maximize On Play" before running the game for the first time - or in builds?

  • Recreated. In the meantime, precede the Menu: Change state Action with an Engine: Wait Action with a wait time of -1.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!