Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

2019.3 Complications

edited January 30 in Technical Q&A

Hi,

I've updated both AC and Unity to current versions.
2019.3.0f6 is now official full release, but I'm not sure if its yet supported by AC.

Anyway after the update the first selected element option in menus stopped working.
Besides that I'm just getting two warnings, otherwise it seems to be working as expected.

  1. PlayerSettings.virtualRealitySupported is obsolete
  2. Overriding existing asset with new GUID from package, this may break links within your project to package assets (Assets/AdventureCreator/Graphics/PrefabIcons/_Camera.png)

Is it recommended to not update to 2019.3 just yet?

Comments

  • Yeah, I'd like to know about the situation with 2019.3 too. These seem harmless so far.

  • As a whole, 2019.3 should be fine to use with AC. Issues will be addressed as they are reported.

    The two warnings you're getting can be ignored - though I'll try to do something about the first.

    As for the "First selected element" option - what is your AC version, and did you update AC at the same time? Let's please see screenshots of your Settings Manager, and full Menu Manager with a typical problematic Menu's properties.

  • edited January 31

    Alright, thanks for the info.

    I can now confirm that the "First selected element" issue was not related to Unity update. I was updating AC from 1.68.3 to 1.70.2. Based on your response I've compared Menu Managers before and after the update and these two checkboxes got unchecked. Rechecking them solved the issue. Thanks.

  • I've noticed something else. The first time I run the game in the editor (from any scene) I get these two warnings. Seems to be pointing to AC. Happens only the first time the Play button is pressed.

  • It looks to be referring to a missing script that was attached to one of your Canvas prefabs - though I can't tell if this was a custom script or not.

  • I've manually looked into every canvas prefab and there's no missing script. Any tips how to debug such thing?

  • Clicking the message at runtime should point you to the GameObject it's referring to.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!