Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Cutscene and Interaction actions deleted

I'm just checking to see if any similar issue has been reported before, I tried searching but couldn't find anything. I've experienced a couple of times over the past year now that I'll find that all my in scene ActionLists (Cutscenes and Interactions) all get 'wiped', so the Gameobject with the Cutscene/Interation is still in the scene and they are still linked correctly to the the relevant hotspots etc however the actions of every single one are deleted and they all simply have the default action list set of having the Engine: Wait action and that's all (so the default action list set of actions when creating a new action list.

I fully understand that without any further information on when this occurs or any other information to help recreate this becomes quite impossible to solve however I just wondered if anything similar has been reported before? In the meantime I'm still trying to recreate reliably to help with solving the issue.

Thankfully I backup my project extremely regularly and simply copying over the backed up .unity scene file for the scene where I lose the action list data works to recover the lost actions (obviously not any changes made after that last backup). So this post is just to ask if you have any idea of what may be causing this to help with me recreate? And have you had anything similar happen before?

p.s. it has happened a couple of times and the last time as recent with the latest version of unity and AC running (2019.2.15f1 and AC 1.69.5) and I'm on the HDRP pipeline.

Comments

  • Troubling to hear. Certainly I'm not aware of such an issue, though it's hard to say if this is an issue with your particular project, with AC, or with Unity.

    • Was this at the same time as you were script compiling / enocountering a red scripting Error in the Console?
    • When the Actions were replaced by defaults, were they chained together / positioned as before?
    • In your Editor Settings, what is your "Asset Serialization Mode" set to?
  • Hey Chris, thanks again for your excellent support! To answer your questions in order:

    • It is hard to say as each time it has happened I only realised when playing the scene to test it and being perplexed as to why the game wasn't starting properly (and then I'd look at the OnStart cutscene and realise it was all deleted and then realise that all others were deleted). However script compiling errors and red messages are a frequent occurrence with me (and I do have some custom actions - wondering if there is a particular link there with custom actions encountering a compiling error? I'll test that out my end to see if I can replicate it).
    • No all actions were deleted and the list was replaced by 1 single default Engine:Wait action regardless of how many actions the list previously had and how they were connected.
    • I've checked and the "Asset Serialization Mode" is set to Force Text.
  • edited December 2019

    I'd say it's likely that the custom Actions aren't to blame. If it were, I'd expect only issues with ActionLists that use them - and I'm assuming that at least some of your affected ActionLists were just using "vanilla" Actions.

    As all ActionLists require at least one Action, AC will auto-populate any empty lists that it finds with a single default Action. That you're getting default Engine: Wait Actions is just a side-effect of the fact that the data is lost.

    How or why the data is lost is uncertain - again, it could be a Unity issue since this data is all part of the scene. It may be worth setting the serialization mode back to it's default value of Mixed, at least so far as testing goes, since that at least is a key difference from most projects.

    Apologies that I can't give much more specific advice at this stage. If you can find a way to reliably reproduce the issue, please share steps and I will look into it.

  • No worries at all Chris, I fully expected as much given the fact that I can't give any reliable repeatable information to repeat the problem for you to actually investigate. I fully appreciate the help you've already given despite the lack of info.

    I'll play around with some testing using the different serialization mode. Just to clarify 'Force Text' isn't default then? I'm wondering why it is changed then and not set to Mixed? Sorry, just rambling, I'll look into some testing and get back to you if I can pinpoint anything in particular that may be causing it. Thanks again.

  • Just to clarify 'Force Text' isn't default then?

    IIRC, no - though perhaps this has changed with Unity.

  • Yeah it might have Chris as the Unity site says that Force Text is indeed the default.

    Anyway I've still not been able to replicate the issue however I do recall some info that I should have mentioned before however it completely slipped my mind so apologies for that. When the issue happened I'm pretty certain now that each time I lost the AC windows that I had docked in my project screen (so I have the 'AC Game Editor' as well as the 'Action List Editor' windows docked in the top right of my project screen). I recall that these were no longer there however AC was still installed as it was still available in the dropdown selections at the top of the window where 'File', 'Edit', 'Assets' etc are located. So I had to click on the AC dropdown menu and then select the 'AC Game Editor' and 'Action List Editor' to bring them back up and then re-dock them.

    Again though I fully understand that whilst this is some added info it is not very helpful for troubleshooting. It definitely seems that the issue is being caused externally to AC though considering the issue hasn't been reported before by anyone else. Regardless I will still try to recreate though because obviously either way even if AC isn't the cause I'm sure you'd like to know.

  • Could your Scene actionlists possibly be nested in a prefab that is somehow getting wiped at run time?

  • edited December 2019

    Good point, @brentk!

    ActionLists cannot survive in prefabs - hence the need for separate ActionList assets. With the introduction of Unity's nested prefabs, AC now auto-disconnects prefab links when creating e.g. Cutscenes etc in the Scene Manager.

    This isn't retroactive, however - so scene-based ActionLists made prior to Unity 2018.3 using the Scene Manager will still be prefab linked, and would need to be manually disconnected.

    Are your scene-based ActionLists instances of prefabs, @mjbcfc?

  • Are your scene-based ActionLists instances of prefabs, @mjbcfc?

    Ah good point however I made sure straight away after that change was implemented that I unlinked all my scene based AL's so they aren't prefab instances (and never have been in the scene I'm working on as it was created after the aforementioned Unity/AC changes were made).

  • I never could replicate this issue again Chris however I have just updated my project from Unity 2019.2 to 2019.3 and the issue has happened again with all my scene based Cutscene and Interactions again being 'wiped'. I understand that updating a project between Unity versions is never exactly smooth (and I have a backup of my project so I can easily reproduce the lost Action Lists). However any idea how the specific data of the actions is getting lost? The GameObjects are still in the scene and they still have the Interaction or Cutscene script on, but the Actions have been wiped and reset (as mentioned above).

  • So the wiping occured specifically at the point you upgraded Unity versions? If so, this may be more a question for Unity's engineers.

    Do you have a backup pre-wipe of the Unity 2019.2 version? Such that importing this into Unity 2019.3 wipes the Actions? If so, I can take a look at it over PM.

    You wouldn't need the whole project - if you duplicate the backup, you can remove the AC Demo folders and all your art/animation assets, as well as all scenes except just one example that demonstrates the issue.

  • Thanks Chris, so helpful - yes I have a backup, I will test it out a few times to see if the actions do indeed wipe upon updating to 2019.3 each time before I send it to ensure it is repeatable.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!