Forum rules - please read before posting.

tex mesh pro rich text tag filter freezing dialog.

Well, as my original message went lost in the void due to editing it (and waiting for review) and is quite an important matter I need to fix.. I'll better ask again.

I updated to last version. In new version, all the dialogues that have rich text that is referenced in the dialogue script/game engine object, the dialogue (as then the game), freezes and don't continue. It's quite important to fix in order to update my release, so please... I've been searching in forums and manual, tried the discord... and there is little information.

I guess more information maybe needed, it's in the post waiting for reviewing... And if it's lost, well, I'll guess I'll post it again.

Thanks.

Comments

  • edited May 2019

    Apologies for the auto-spam-flag. I've verified your account, so it won't happen again. For completeness, I'll paste the original post here:

    So I finally updated to last version (1.67.5). Using Unity 2018.3. 4f1

    My last version was 1.66.2 I THINK...

    TextMeshProIsPresent.

    After updating (mainly to use the timescale as a parameter, and that worked perfect), I found that whenever a richtagged text shows, the dialogue "freezes". Exactly what happens is that when I click to skip the current text, It doesnt go away. I can see the richtagged text flicker, like it is recomputing the richtext effect. (the tags don't show, but renders the game unplayable)

    I didn't touch anything about richtext not now nor before.. I only know that before, the rich text hidden in scrolling didn't work as expected (It showed the tags for miliseconds), but =>

    If I remove the richtext tags from the GameEngine object of a specific scene, then the dialogue work as expected.
    But of course I'd like to have the richtext tag hidding on scrolling.

    Maybe on the update, there's some option that I don't know because there is not much documentation on the manual about textmesh pro and rich text... I don't know,

    My text options:
    https://imgur.com/B6DJ84F

    Did you also upgrade Unity or TextMesh Pro at the same time, or was the issue only the result of updating AC?

    Are you relying on custom rich text tags, or built-in ones such as , etc? I will need some sample text so that I can attempt a recreation.

    You mention TextMeshPro in the title. Is this only occuring when using TextMeshPro? If you switch your Subtitle menu's Source back to Adventure Creator, so that TMPro is temporarily ignored, does it then work?

  • edited May 2019

    Just only updated AC. Textmeshpro version i've using it without problems since the beggining, even before AC integration ( I used the old hancrafty integration script of the forums). Some months ago I integrated it officially and worked fine (well, the rich text tag obscuration let show them for miliseconds, but didn't freeze the text)

    as I said, I didn't add more tags nor remove. Everything is as default.

    text Mesh pro version is 1.3.0. I could update to 1.4.0, but I think i do it in the past and get some problems and I rolled back. I think. But I have made investigations:

    Setting back the subtitle menu to adventure creator work and freezes in the same game as my own subtitle menu with text mesh pro, so it' may seem them that is a richtext tag thing not related with text mesh pro..?

    I created a dummy interaction with the following texts to try:
    <b>hello.</b>
    -It freezes. It apllied the effect.
    <i>hello.</i>
    -it freezes.It apllied the effect.
    Hello.
    -Works.
    <size=300%>Hello.
    -It don't freezes! but Does not apply the size effect!
    <color=white>Hello.
    -It don't freezes! but Does not apply the color effect

    I also tested one I've never used, to use some of the "iftxtmeshproinstalled":
    <u>hello.</u>
    -It frezzes.It apllied the effect.

    As conclusion, I can see that the richt text tags with closing arguments work but freeze the game, and non closing arguments don't freeze the game but don't work...

    After seeing the results of this test, I'm quite puzzled.
    Also, It's quite important for my game having rich text tagging in lack of speech so... I hope we find a solution.

  • Well the forum formatting...... < b > hello < / b > .. etc.

  • Yes. I returned to previous scenes, changed the rich text tags on GameEngine b and i to z and h (in order to not freeze the dialogue, and see how other working tags worked out, and the color and size tags don't do nothing since the update. Like the parser just ignore them.

    It may not have nothing to do with textmeshpro, Rich text is activated in the textmeshpro instances of the menus as always. (As I didn't touch anything except just update AC). Problem may be somewhere in the dialog.cs....? I don't understand why it will apply Bold and freeze the game and Not apply Size... that options are default for text, not even IfTextMeshProIsPresent.

    When I updated AC, I just unchecked the reference.asset in order to not loss the menu. May I have lack an script or something?...

  • edited May 2019

    I found the option Scale Text Effects in Global Menu Settings. I do not know if that option existed before, but I checked and in one scene it made the size work again. (In a gathered text dialogue line, I don't know if that is relevant). I'm trying in the dummy interaction with

    <color=blue>Hello Color <b>Hello Bold </b> <i> Hello Italics </i> <size=500%>Hello Size And not the size nor the color applies. The bold and italics work and freeze the game, if not changed the rich tag in the game engine object.

    I went back to check if gathered speech lines worked the color, like the size in the other ocasion. And the color didn't work.

    I'm to gather all text again.
    -> no change.

    If this Scale Text Effects option was a thing, I wonder if there are more options I'm not aware of..

  • This is an issue related to the Skipping speech first displays currently-scrolling text? option in the Speech Manager.

    I shall PM you a link to a test replacement of Speech.cs that should resolve it.

  • At least I had no broken anything this time I guess.

    Script had solved Bold and Italics. Now they work perfectly.

    But Size and color, don't. Now, when I click in order to pass to next dialogue, it flicker during a milisecond with the appropiate color and size, but returns to a game freezing dialogue box without the effects applied. I run several tests in order to see what happens. The color effects I'm not sure what's happening because the flicker is too fast.

    In a possible non related question, "Scale Text effects" option in menu manager is of no consequence using my setup? (text mesh pro etc).

  • edited May 2019

    But Size and color, don't.

    I will continue investigating. Does unchecking the option I mentioned above stop the issue from occuring?

    "Scale Text effects" option in menu manager is of no consequence using my setup? (text mesh pro etc).

    This option only deals with AC-rendered menus. When using Unity UI or TextMeshPro, all styling options are left to the components that make up the UI prefab.

  • I was hyped implementing the script and forget about checking what you mentioned about the option.

    tests:
    Color and Size break the game as described, and If changed the name of the tags on the rich text GameEngine slots, they applied correctly and lets the game continue but with the expected seeing the tagging for miliseconds.
    (so, as before).

    I restore the rich text tags on Gameengine and then:
    Uncheking: Skipping speech first displays currently-scrolling text?

    The dialogues doesn't freeze the game, but nor color nor size is applied. (sadly I cannot use this option in release but at least I can keep working with that uncheked temporary).

  • edited May 2019

    I cannot find any issue with the color/size tags. Does this too remain if you switch your Menu's Source back to Adventure Creator?

    This is the text I am testing with:

    <color=blue>Hello Color</color> <b>Hello Bold </b> <i> Hello Italics </i> <size=200%>Hello Size</size>

  • edited May 2019

    Edit: Wait, I'm not using closing arguments for color and size, they were not needed before. I'm gonna check.


    With And Without Skipping speech first displays currently-scrolling text, there's problems related to color= and size= assigned to the GameEngine Dialog rich text tags.
    (With: does not compute color nor size and it freeze the dialog (showing correct color and size for a moment), so, same problem that before with bold and italic, now fixed.

    ** Without**, it just not compute the color and size.

    If I change size= and color= to another words, With or Without, the game doesnt freeze, it just show the tag all along as expected.

    Yes, I tested with the menu source to adventure creator, same problem as before, if fails the same.

    It's exactly exactly the same behaviour that before your fix to bold of italics. Just keeps happening with Size and Color.

  • Yes, using closing arguments for color and size, it works.

    I didn't use them before because Textmesh pro doesn't need them, and all worked. I guess I should just fix all the text not using closing argument for color and size...

    So now everything fixed! I hope! nice! Thanks!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!