Forum rules - please read before posting.

Slowdown after loading speech audio files

Hello,
I'm using AC 1.60.7 and Unity 2017.1.1f1 for a 2d adventure.

I have some issues after loading speech audio files. I load 440 files .wav (about 100 mb in total (it's a 1/10 of the entire speech audio files)). I load them in Resources/Speech/Name character (all files are of main character), but, after loading them, I note a slowdown when I switch between scenes. Without the audio speech files the switch is immediate, while with the speech audio files it takes about 2 seconds. I'm worried when I have to load all the files for speech.

I think I read a possible solution in the forum, but I can't find the post.

Thank you very much.

Comments

  • The next AC update will allow the optional use of AssetBundles, as opposed to Resources folders, to automatically playback speech audio - this should help with performance times.

  • ok, thank you Chris. Actually is there a way to reduce this problem? If I assign manually the name of the voice file to the text could be better or nothing change? I ask before start to associate more than 400 files.

  • This script on the wiki lets you convert between the manual and association modes:
    https://adventure-creator.wikia.com/wiki/Auto-assign_custom_speech_audio

    The update should reduce the problem, however - ETA is next week.

  • Thank you Chris, I tried the script, following the instructions but I have some errors in the console and seems don't work:

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(143,57): error CS1061: Type AC.SpeechManager' does not contain a definition for GetAutoAssetPathAndName' and no extension method GetAutoAssetPathAndName' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(221,56): error CS1061: Type AC.SpeechManager' does not contain a definition for autoSpeechFolder' and no extension method autoSpeechFolder' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(225,35): error CS1061: Type AC.SpeechManager' does not contain a definition for autoSpeechFolder' and no extension method autoSpeechFolder' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(245,90): error CS1061: Type AC.SpeechManager' does not contain a definition for autoSpeechFolder' and no extension method autoSpeechFolder' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(249,86): error CS1061: Type AC.SpeechManager' does not contain a definition for autoSpeechFolder' and no extension method autoSpeechFolder' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    Assets/WillyMorgan_R02/Editor/CustomAudioManagement.cs(436,69): error CS1061: Type AC.SpeechManager' does not contain a definition for autoSpeechFolder' and no extension method autoSpeechFolder' of type AC.SpeechManager' could be found. Are you missing an assembly reference?

    I'm not so skillful with scripting so I don't know how to solve. Maybe the new update is the best solution.

  • You need to be using the latest update for it to work.

  • Hi, I update to 1.66.1, but, before using AssetBundles, I tried the script in https://adventure-creator.wikia.com/wiki/Auto-assign_custom_speech_audio.

    I don't know why, but it seems no to work. Now I can use it without errors: I use Adventure Creator/Speech audio management/Assign resources audio manually and it works fine. It report me that all files are assigned correctly, but when I start the game to try them, I can't listen audio speech. I went on speech and I see the link to the correct files, but on game nothing. I have no error messages on console.

    The only thing I noted: my original files are .wav, after the manually process (via script), I think the extension change (when I click on a file, it can't be reproduce with the standard app).

    When I make "rename manual audio to automatic" and set "Auto-name speech audio files" all is correct again.

    Am I missing something?

    thank you again

  • Are you able to play the audio from the bottom of a file's Inspector? The process shouldn't have changed the extension. Try creating a new .wav file and replacing it for one of your regular ones - does that play correctly both in the Inspector and by AC at runtime?

    Be aware that to rely on AssetBundles, you need to start with automatic mode.

  • I solved with the script: I have two languages and I have to check "Speech audio can be translated" and "Use original language audio if non found". Now it's all very quick and the switch between the scenes is always fast. In the next days I want to try with the new AssetBundles.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!