Forum rules - please read before posting.

Precision issue

Hi everyone,
I have an annoying issue with some animations. I used AC 1.60.7 with Unity 2017.1.1f1 and I'm working on a 2d game.

I have this type of problem: I have an object in a scene (sprite). The character has to take it, so he walks to the marker and then there's a custom animation where the character takes it. When animation starts I hide the visibility of the object because in the object is already in the animation frames. 
The issue is that if I try several times, some time the original object is aligned with the animation, but other times is not perfect aligned and I think the problem when character goes to the marker (some time is in the perfect place, some times he's not perfeclty in the righ place). 

So, some times my character takes it and all is fluid, but some times I see a different position of the original object compared to the same in the animation, like if the character starts the action some cm before the marker position.

Is there a possible solution?

Thank you

Comments

  • See the "Precision movement" chapter of the Manual for tips on getting precise movement.

    There is also a "Retro-mode" movement in your Player Inspector that, while designed to best work with classic low-res 2D games, does feature precision when moving without need for any other considerations.

    If need be, you could always position the player exactly using Object: Transform or Object: Teleport, but the above should help you before that becomes necessary.
  • Thank you very much Chris, I try.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!