Forum rules - please read before posting.

Animation glitch is back... :( HELP!!!

Dear fellow AC users, Master Chris - I'm in trouble again...

A few months ago I'd reported this game breaking animation glitch issue:

I got rid of it, by making a new scene and making it scene 0 at the start of the game and for reasons I didn't want to understand then ( magic?) that made the problem go away.


Here's what it looks like now:

I've tried a lot of things today to fix it. The magic doesn't work anymore.  I made new scenes with just a basic playerStart2D in them, trying to isolate the problem, whether it's the camera or wrong character's rotation or... I don't even know! To me it looks like there are 100 animations playing all at once, and some of them seem to be other NPCs' animations too...

For testing, I made a new player character with just 2 basic animations and it was NOT glitching.

This is happening only in the game's build.

Using Unity ver 5.3.4f1 personal. AC ver 1.52a. Platform: Windows PC x86_64 Animating using Sprites Unity method.

I'll post screenshots of all necessary details, just let me know what needs looking at.

Could this be related to the sprite settings maybe? This is the one I use for importing sprites:


- this might be unrelated but does having "generate mip maps" ticked affect the size of the game (it's 15GB already) and loading time (at start up it takes 1-2 minutes to launch the build)? - cos it made me think the loading time and this horrible glitch might be caused by a totally over-sized player character packed of animations (some sort of system overload?). I could go through all the sprites and untick that box everywhere in less than half an hour probably... but maybe I'm going in a completely wrong direction and that's not needed (though I would love to shrink the game's size)...

I apologize for the lengthy post. It's just that I'm panicking, guys! I've spent a year working on this game, it's all coming along wonderfully. I'm doing this for a living, so that's another factor, as well...

But I can't fix this one without your help.



  • Umm, have you tried checking the character's animator during playmode while this is happening. Though, you said it only happens in a built version right?...
    Anyway, when did this problem start to happen again? Do you remember if you did anything special around the time it started? Also, Maybe you should try making a copy of you project, then install the latest version of Unity and AC and see if the problem persist if you use the new versions (remember you can have multiple versions of Unity installed, just install the new Unity into a different folder than the previous version). That way you can test the copy project in the newest Unity and AC, without altering the original.
  • Yeah, it's happening only in the build version. Animator in editor shows correct animations playing, though.

    I haven't made a build for 2-3 months. Before it worked fine. I don't think I did anything different in the meantime. If anything, I learned more how to use program more effficiently. But the number of animations definitely increased. Player has literally thousands of frames of animations on her, and if they are all 2mb each frame (as the screenshot attached suggests,with mip maps) could that be a problem?

    I didn't know you can have 2 versions of Unity installed! I will try that + updating AC. Thanks. I will report how it went.

    In the meantime, if anyone has any other ideas and if you could tell me about mip maps, that would be very very very much appreciated.
  • EDIT: So far updated to new version of Unity. Haven't made a build yet but some new warnings showed up (Lorelai_Main is the player prefab):

    The Animator Controller (LorelaiAltController) you have used is not valid. Animations will not play
    UnityEngine.Object:Instantiate(Player, Vector3, Quaternion)
    AC.KickStarter:ResetPlayer(Player, Int32, Boolean, Quaternion, Boolean, Boolean) (at Assets/AdventureCreator/Scripts/Game engine/KickStarter.cs:821)
    AC.KickStarter:OnAwake() (at Assets/AdventureCreator/Scripts/Game engine/KickStarter.cs:944)
    AC.MultiSceneChecker:Awake() (at Assets/AdventureCreator/Scripts/Game engine/MultiSceneChecker.cs:46)


    GameObject Lorelai_Main was not saved because its ConstantID has not been set!

    UnityEngine.Debug:LogWarning(Object, Object)
    AC.ACDebug:LogWarning(Object, Object) (at Assets/AdventureCreator/Scripts/Static/ACDebug.cs:26)
    AC.LevelStorage:PopulateScriptData(SubScene) (at Assets/AdventureCreator/Scripts/Save system/LevelStorage.cs:436)
    AC.LevelStorage:SendSceneToData(SubScene) (at Assets/AdventureCreator/Scripts/Save system/LevelStorage.cs:201)
    AC.LevelStorage:StoreAllOpenLevelData() (at Assets/AdventureCreator/Scripts/Save system/LevelStorage.cs:175)
    AC.SceneChanger:PrepareSceneForExit(Boolean, Boolean) (at Assets/AdventureCreator/Scripts/Game engine/SceneChanger.cs:406)
    AC.SceneChanger:ChangeScene(SceneInfo, Boolean, Boolean) (at Assets/AdventureCreator/Scripts/Game engine/SceneChanger.cs:153)
    AC.ActionScene:ChangeScene() (at Assets/AdventureCreator/Scripts/Actions/ActionScene.cs:112)
    AC.ActionScene:Run() (at Assets/AdventureCreator/Scripts/Actions/ActionScene.cs:63)
    AC.<RunAction>c__Iterator2:MoveNext() (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:324)
    UnityEngine.MonoBehaviour:StartCoroutine(String, Object)
    AC.ActionList:ProcessAction(Int32) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:288)
    AC.ActionList:ProcessActionEnd(ActionEnd, Int32, Boolean) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:475)
    AC.ActionList:EndAction(Action) (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:393)
    AC.<RunAction>c__Iterator2:MoveNext() (at Assets/AdventureCreator/Scripts/ActionList/ActionList.cs:362)
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)


    The Animator Controller (LorelaiAltController) you have used is not valid. Animations will not play

    And yet the animations are playing just fine when I launch the game in editor.

    I will update AC later on and make a build to see if anything's changed.
  • And this is in the newest Unity and AC versions? Well the only thing I found about this error was this forum topic on the net.

    I doubt the weight of the images you have for your animation will make any difference, but, maybe it could be a problem with the animator. If you have the backup for the old Unity version you could try to right click the animator, in the project window, then selecting reimport. Else, in either version, you could test by making a new animator with just the basic animations and see if you have the same problem with it. If it works, it might pay off to remake the whole animator.
  • I'd say the Console error is definitely related.  Are you using AssetBundles?  A google search shows a few reported cases of this issue that makes use of it:

    There's also one that doesn't appear to:

    You could see if the mip map setting affects it by unchecking it, and building, in a duplicate project.

    Whatever the cause, I'd mark this down as a Unity issue, though I'd happily be proven wrong.  AC doesn't moddify your Animator Controller aside from changing parameter values at runtime, but that wouldn't invalidate anything.  Unfortunate though it may be, I'd second @Alverik's suggestion and work on rebuilding the controller.
  • I've replaced the Animator controller (just the few basic animations for now but adding the rest is a simple matter of drag and drop) and yeah, it fixed it ;)

    Thanks for the suggestion Alverik!

    Funnily enough, the error only showed up after updating Unity.

    Also, unchecking mip maps on player's sprites only has trimmed the game down by a whopping 5GB! I'm gonna do that for the rest of the characters and backgrounds, I'm sure I can bring it down a LOT more ;)

    PHEW! ;)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.