Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Deactivate automatic scaling

edited May 2014 in Technical Q&A
Is it possible to deactivate the auto-scaling to emulate depth effect - I'd like like the character to move between x/y-axis without changing it's size like in a normal Jump'n'run.

Comments

  • It would help a lot if you can include few details about your project and as how your using sorting layer.

    Suggestion 1
    Im assuming you are using 2d-Topdown workflow. If so, your out of luck and the only way you can over comethis problem is to check your project as if you can simulate the 2d-Topdown structure with other 2d views which will not restrict your character to strict 2d plain.

    Just like in the 2d demo, you can create a 3 dimensional scene with 2d sprites, giving the 2d topdown illusion. The only thng you need to really pay attention is whether you can create a good nav mesh which will fit your bg floor.

    Once you do that, you can "jump" (is there a jump in AC?") and move up the stairs in front of the scene without having your character getting scaled.
    Suggestion 2
    There was also another topic on the matter which Chriss has provided an alternative solution to what i'm suggesting.
  • Hey,

    thanks again for the tipps, will check them out  In this concept I am working on a robot is harvesting different diamonds inside a cave and is able to fly around within the x/y-axis to get those diamonds even from the roof or the walls. So in this case no scaling will be necessary for the y-axis...
  • Just found this video to demonstrate what I mean: 

    Here Guybrush is not scaling when moving within y-axis.
  • edited May 2014
    ok, just like i've mentioned in the previous topic. Use sorting layer but keep the  "End Scale ( % )"  as "100"  or what other size number you find suitable.  If all your sorting positions have the same  % than your character wont resize.

    Give it a try, it will work.
  • There is an option within the sorting map options to handle the character's scale - if you turn it off the scale keeps at 100% - thanks for pointing me in the right direction!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!