Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Update to 1.33b Removes Hot Spot/Speech/Convo Functionality

Previous updates have had no problem but since updating to 1.33b any wording, be it Hot Spot description, speech or dialog options aren't visible anymore?

I have the same Menu Manager as always so I'm baffled :/

Any ideas guys?

Comments

  • First steps:

    1) Top menu, Adventure Creator -> Getting started -> Load 3D Demo Managers, and run the 3D demo.  Do the Menus display then?

    2) If so, load in your own managers, EXCEPT for the Menu Manager (leave that as Demo_MenuManager).  Does that work?
  • Hi Chris

    Regarding step 1, I did what you've said and the demo doesn't display any menus, hotspots or dialogs either.

  • EDIT: also, deleting the AC folder and doing a totally fresh re-import still isn't working.
  • I've tried loads of different things but they've all failed. It looks like 1.31 is as far as I go :(
  • I haven't given up yet ;)

    Let's try creating an entirely new project and importing in just AC 1.33.  Get the Demo game running first of all, and nothing else.  THEN go about transferring your game's assets from your old project to the new.  You can use Unity's export/import package features to transfer them - just be sure to keep any AC assets out of it, so nothing gets overwritten in the new project.
  • Thanks Chris - I tried this EXACTLY as you've said with a fresh install of AC and imported my project EXCEPT any AC folders/files but it's exactly the same. So still no luck :(
  • But how far did you get, exactly?  Did you get the Demo game running before you imported your own project?  And what exactly happens when you do import?  Any errors in the console?  Screenshots always help.
  • The Demo game worked flawlessly. as soon as I imported my assets, the hotspots and dialog vanished. Yet it works fine with 1.31.
  • Not that I'm hoping this is the case, but your Menu Manager may have been corrupted somehow.  Does your game run OK, otherwise?

    Set your Menu Manager to the Demo_MenuManager asset and see if Hotspots and Dialogue show up then.  If so, you may have to rebuild your Menu Manager.  You can use the New Game Wizard to duplicate the Demo's one.  It wouldn't be the ideal solution, but let's figure out at least how to get things working.
  • It works fine when I go back to 1.31 again so I don't think it's corrupt. It's as soon as I install 1.33b it just doesn't seem to work. But in 1.33b, apart from the missing hotpsots/dialog, everything else works fine.

    I'll have a play with the MenuManagers and let you know.

    Thanks so far Chris :)

  • edited May 2014
    @ChrisIceBox

    I've tried using the Demo_MenuManager from the demo files but it still doesn't work.

    Again though, it all works seamlessly when I restore my 1.31 files.

    EDIT: I've also noticed that the inventory doesn't appear, nor does it always change rooms; sometimes it fades to black and just stays there.
  • PM me your set of Managers.
  • Hi Chris

    I've sent the PM :)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!