Forum rules - please read before posting.

Dialogue repeating twice for some reason [Bug?]

Hi, I have a Dialogue: Play speech that says "A few minutes later..." and for some reason it says the line first in background, then it says it again and pauses until you skip.. I don't understand what could cause this, I have no other Dialogue: Play speech in the scene or ActionList that says it apart from that one.

Screenshot of the ActionList:

This is what the first one looks like, it's already started fading from playing in background:

Then it shows the exact same text a second time, and I have to press left click to get past it.

If there's something easy I'm missing, please let me know. Otherwise, I'm pretty sure this is a bug. I've restarted Unity and it hasn't fixed it.


  • Just a bit more info, I have other Narration in the scene that works perfectly, it's just this one single piece of dialogue that's messed up.

    My speech settings:

    My Narration menu settings:

  • Is the ActionList itself set to run in the background, and how long does it last after the dialogue has been triggered?

    If other narration is working with your settings, it may be down to some setting/configuration that's hard to convey through screenshots.

    If you duplicate the scene and assign this ActionList as your OnStart cutscene, does the issue occur when the scene begins? If so, see if you can create a .unitypackage file containing both the scene file and your game's Managers. If you can PM it to me, I'll be able to more accurately recreate the problem.

  • Thanks for the help Chris, I just didn't realise something simple cause I'm still learning. So I duplicated the scene like you said and then started randomly deleting random sections of the ActionList and through trial and error figured out the reason it was happening. I had a "Run in parallel" where two actions both led back to the text, that's why it was playing twice. I didn't realise it worked this way. Here's a screenshot showing the mistake I made:

    It's working perfectly now, so it's not a bug, just me not understanding how it worked haha. I got so many other little problems too like the Music storage not working for me at all as well the Camera follow during a cutscene not working, but instead of always defaulting to "maybe it's bugged", I'll just spend a lot more time trying to figure it out. :smile:

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.