Forum rules - please read before posting.

I can't change footsteps sounds

Hi everyone,
AC 1.70.0 + Unity 2019.2.17f1 on a 2d game.

My character has a child (footsteps) with footsteps sound script attached. I tried to change the sound. I started with the easier way, changing the footsteps sound on a start cutscene, so every scenes could have different footsteps sounds based on the type of floor (sound/change footsteps). But nothing change: I hear only the standard footsteps attached to the character.
Then I tried to make a Trigger2d and, as action list, again Sound /change footsteps, but also in this case nothing changes.
I can't understand where's my fault.

Thank you.


  • Are you getting any relevant warnings or messages in the Console when the ActionList is run? Be aware that, to aid testing, you can run an ActionList manually by clicking the "Run now" button in its Inspector.

    Check that you haven't got any walk/run sounds assigned in the character's root Player Inspector. If you need more help, I'll need to see screens of the character's Inspector, the FootstepSounds component, and the Action you're running.

  • Thank you Chris. Finally I solved: I had a Footsteps script attached to the root. It was disabled, but it was necessary to delete it and then all works well.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.
Do NOT follow this link or you will be banned from the site!