Forum rules - please read before posting.
Tech questions during the weekend? Drop in on the community Discord channel!

Video Player not pause

I had some problems with the video player and the pause menu. 
When I press ESC to active the pause menu the animation continue background and the sound two. The menu is a Unity UI Prefab and has the same configuration that the demo has.

I found VideoPlayer.Pause option in unity but I don´t know if I have to go that way or something else. 

I have the last version of Unity Unity 2018.2.0f2 (64-bit)
AC 1.62.5

Comments

  • I'll attempt a recreation.  Let's see your VideoPlayer Inspector and Engine: Play movie clip Actions, please.
  • This isn't a bug, but the behaviour can be set with a custom script:

  • That's a separate issue - or does that only occur after pausing/resuming?

    There are no more Actions in your screenshot - do you mean that gameplay resumes?  After which point, exactly?

    Does unchecking "Wait For First Frame" make a difference?
  • That's a separate issue - or does that only occur after pausing/resuming?
    Only when pause/resume

    There are no more Actions in your screenshot - do you mean that gameplay resumes?  After which point, exactly?
    Resume immediately the video player. So continue with the next task.

     Does unchecking "Wait For First Frame" make a difference?
    Nothing happened. The same with the check or uncheck.

    Now, something else but weirder. Its pause the video but in the resume, continue with the next task and the video in parallel. 
     
  • Recreated, will look into it.
  • There'll need to be a tighter integration between the custom script and the Action.  I'll combine both into the next release - you won't need a separate script.
  • I can Well, the solution in the new update works great!

    But something new happened now. It's really weird because in some videos with the pause option and without the loop option, start looping indefinitely. I can get where is the problem because some videos do but others don´t with the same specification. I have only thought are the larger ones that have this problem but i take a look again and some shorter have it to this problem. This only happens with the pause options enable.
     
  • The Action itself doesn't affect the looping property.  Does the Video Player's loop field become checked?

    Are you pausing/resuming before the loop occurs, and is it pausing/resuming correctly?  If the only difference between working/not working is the video file itself, it may be an issue with Unity.
  • Does the Video Player's loop field become checked? NO. But I have checked only to look what happened and surprise skips the video doesn't play it at all.
     Are you pausing/resuming before the loop occurs, and is it pausing/resuming correctly? Yes.
    Now I´m updating the last last version of Unity. 
  • The same with new versión. And didn´t find any bug with the video player. 
  • edited July 2018
    The behaviour is now changing?  Is it looping, or skipping?  If skipping, when?

    Please explain as clearly as you can what happens and when, and also provide screenshots of the relevant Inspectors / Actions.  Without knowing what exactly is happening, and the steps you are taking to trigger this behaviour, I won't be able to recreate it.

    If swapping out one video for another causes everything to work, then you will also need to describe the details of those two videos - something must be different for the bahaviour to change.
  • Well.

    I test two conditions looping and not looping. If I check loop the video skip. And if I uncheck loop the video start looping. All of these with the pause options checked.

    Otherwise, if I uncheck the pause options work the loop and not looping, but also don´t pause the video.

    Remember I have a pausefocus script that you gave me. But I don´t think the problem is there. 

    The video player ( i try check and uncheck wait for the first frame)
    https://drive.google.com/open?id=1AxjTkA8r0Tns4j42W7sMnKp4lIxoL_N0

    In the cutscene (there is without the pause, but it´s the only solution to not loop
    now, if I check pause get unlimited loop :( )
    https://drive.google.com/open?id=1MYJWYZJQ5v54TgkQZL1CA5fdjU97TqDd

    The properties of the cut
    https://drive.google.com/open?id=1YlR620etUwtb95AeGPrMmJsd0GX3ELh3

    I think it´s a unity bug but it´s weird because if i check the pause get the problems (of infinity loop with the loop uncheck, and the skip if the loop check)
    Another thing the pause when is check works great. But with the loop problem.

    Here is the pausefocus script https://pastebin.com/iQyj7fAT I made a small modification that when you get out of focus my pause menu appear. 

    Other things but I have taken off and do the same thing. it´s that I have a problem that when I put a video I have to stop them, and disable the transform where the videos are.  

    Here it´s my script. 
    https://pastebin.com/dNtHCC6P

    in the root, I have all the videos players. and control with a global variable when starting the video and disable the root when finishing the video. 
    https://drive.google.com/open?id=1KOC5OUF6xgM26DvcS33z2uKU8Qj5WzE5
  • The PauseFocus script is not necessary with the update.  Remove it, and check the new Pause when game does? option.
  • Nothing happened. The same weird problem. I remove it from all the scenes and now doesn´t work the focus with the videos. If I change focus the video skip. But if I'm in the same window continue looping. 
  • Create a test scene for me and PM it as a .unitypackage file, including the video asset you're using.  Strip your ActionList down to the bare minimum needed to see the problem, and do not include any non-AC scripts.
  • edited May 2019

    I'm having a similar issue here. The 'Pause when video does?' tick box in the Video Player action is only accessible when the 'Wait until finish?' option is selected. However, when 'Wait until finish?' is selected, the in-game menus aren't even accessible to even allow the player to pause...I'd like the in-game menu visible whilst videos are playing, thus giving the player the option to pause the game (and the video). Is there any workaround for this?

  • The Action must have Wait until finish? checked for the option to be visible, as it requires the Action to check for the pause state for the video's duration.

    If the ActionList its placed in is set to block gameplay, then Menus that only show during gameplay will be hidden (though you can still use inputs to show up a pause menu).

    You can either change the in-game Menu's Appear type to Manual so that you have complete control over when it's shown, or set the ActionList's When running field to Run In Background so that it doesn't block gameplay. The Engine: Manage systems Action can be used before and after the video Action to temporarily disable e.g. movement and interactions.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the official forum for Adventure Creator.